Skip to main content

Buy And Sell Stocks - Infinite Transactions Allowed

 1. You are given a number n, representing the number of days.

2. You are given n numbers, where ith number represents price of stock on ith day.

3. You are required to print the maximum profit you can make if you are allowed infinite transactions.

Note: There can be no overlapping transaction. One transaction needs to be closed (a buy followed by a sell) before opening another transaction (another buy)

Input Format

A number n

.. n more elements

Output Format

A number representing the maximum profit you can make if you are allowed infinite transactions.

Constraints

0 <= n <= 20

0 <= n1, n2, .. <= 10

Sample Input

9

11

6

7

19

4

1

6

18

4

Sample Output

30


Solution: 

import java.io.*;

import java.util.*;


public class Main {


    public static void main(String[] args) throws Exception {

        // write your code here

        Scanner sc = new Scanner(System.in);

        int n = sc.nextInt();

        int[] A = new int[n];

        for(int i=0;i<n;i++)

            A[i] = sc.nextInt();

       

        int profit = 0, msf = A[0];

        for(int i=1;i<n;i++){

            if(A[i]>msf){

                profit += A[i] - msf;

            }

            msf = A[i];

        }

        System.out.println(profit);

    }

}

Comments

Popular posts from this blog

UPSEE Counselling 2018 Round 3

UPSEE Counselling 2018 Round 3, AKTU/UPTU Counselling, Started – Register Here UPSEE 2018 Seat Allotment Result (Round 3)  is releasing on  13th July 2018 . It will be conducted through online mode. The university conducts a state level examination in name of Uttar Pradesh State Entrance Exam (UPSEE) for providing admission to the UG & PG courses in the field of engineering, management, etc.  You can get complete information about AKTU Counselling 2018. Here, we are providing details about the schedule, procedure, admission, etc. UPSEE Counselling 2018 –  Seat Allotment Round 2 Result on 10th July Exclusive:  UPSEE 2018 Seat Allotment Result (Round 3) is releasing on 17th July 2018.  Link will be provided here. UPSEE 2018 Counselling User Manual for candidates has been released now.   Click here to view user manual. Click here to view UPSEE 2018 Counselling schedule. Physical reporting will be started on 20th July....

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the ...

Display of Provisional Answer Keys and Question Paper with Recorded Responses for Answer Key Challenge | JEE (Main) 2021 Session 4 for Paper 1 (B.E./B.Tech.)

The JEE (Main) - 2021 Session - 4 was conducted throughout the country and abroad on 26, 27, 31 August and 1 September 2021 for Paper 1 (B.E./B.Tech.) in the Computer Based Test (CBT) mode. The National Testing Agency has uploaded the Provisional Answer Keys for Paper 1 (B.E./B.Tech.) along with the Question Paper with Recorded Responses on the website https://jeemain.nta.nic.in for candidates to challenge. The procedure (as enclosed) for the challenge of Answer Key may be used. The candidates, who are not satisfied with the answer key, may challenge the same by paying a fee of ₹ 200/- (Rupees Two Hundred only) per question challenged as a non-refundable processing fee. This facility is available from 06 September 2021 to 08 September 2021 (up to 10:00 A.M.). The payment of the processing fee may be made through, Debit card/Credit Card/Net Banking/Paytm upto 08 September 2021 (upto 11:00 A.M.). No challenge will be entertained without receipt of the processing fee. The Challenges will ...