Skip to main content

Lucky Number | SnackDown 2021 - Online Qualifiers

Given three digits AB, and C of the lottery ticket, tell whether Chef wins something or not?

Input Format

  • First line will contain T, the number of test cases. Then the test cases follow.
  • Each test case contains a single line of input, three space separated integers A,B,C.

Output Format

For each testcase, output in a single line answer "YES" if Chef wins a positive amount with the lottery and "NO" if not.

You may print each character of the string in uppercase or lowercase (for example, the strings "yEs", "yes", "Yes" and "YES" will all be treated as identical).

Constraints

  • 1T1000
  • 0A,B,C9

Sample Input 1 

3
0 0 0
7 8 9
2 7 7

Sample Output 1 

NO
YES
YES

Explanation

Test Case 1: Since no digit is equal to 7, Chef fails to win any amount in the lottery.

Test Case 2: Since the first digit is equal to 7, Chef will win some amount in the lottery.

Test Case 3: Since the second and third digit is equal to 7, Chef will win some amount in the lottery.

Solution:

import java.util.*;

import java.lang.*;

import java.io.*;


/* Name of the class has to be "Main" only if the class is public. */

class Codechef

{

public static void main (String[] args) throws java.lang.Exception

{

// your code goes here

Scanner sc = new Scanner(System.in);

int t = sc.nextInt();

while(t-- != 0){

    int a = sc.nextInt(), b = sc.nextInt(), c = sc.nextInt();

    if(a == 7 || b == 7 || c==7)

        System.out.println("YES");

    else 

        System.out.println("NO");

}

sc.close();

}

}


Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Classes and Objects, Packages | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text State True or False When using eclipse whichever classes are needed for the present class can be imported automatically. Select one: True   False Feedback The correct answer is 'True'. Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text switch(a) {     default:         System.out.println("Welcome"); } Of which data types can the variable ‘a’ be? 1. long 2. byte 3. int 4. char 5. float 6. short Select one: 3, 4 and 5 1 and 3 3 and 4 2,3, 4 and 6   Feedback Your answer is correct. The variable used in a switch statement can be a byte, short, int, char or String type only. The correct answer is:  2,3, 4 and 6 Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Predict the output.   public class Test {         public static void main(String args[])         {                     int a = 2, b = 0;              for ( ; b < 20; ++b) {                  if (b % a == 0)

Minimum Lights to Activate | Interview

Problem: Description There is a corridor in a Jail which is N units long. Given an array A of size N . The i th index of this array is 0 if the light at i th position is faulty otherwise it is 1. All the lights are of specific power B which if is placed at position X , it can light the corridor from [ X-B+1, X+B-1] . Initially all lights are off. Return the minimum number of lights to be turned ON to light the whole corridor or -1 if the whole corridor cannot be lighted. Problem Constraints 1 <= N <= 1000 1 <= B <= 1000 Input Format First argument is an integer array A where A[i] is either 0 or 1. Second argument is an integer B. Output Format Return the minimum number of lights to be turned ON to light the whole corridor or -1 if the whole corridor cannot be lighted. Example Input Input 1: A = [ 0, 0, 1, 1, 1, 0, 0, 1]. B = 3 Input 2: A = [ 0, 0, 0, 1, 0]. B = 3 Example Output Output 1: 2 Output 2: -1 Example Explanation Explanation 1: In the first configuration,