1. You are given a string str.
2. You are required to calculate and print the count of subsequences of the nature a+b+c+.
For abbc: there are 3 subsequences. abc, abc, abbc
For abcabc: there are 7 subsequences. abc, abc, abbc, aabc, abcc, abc, abc.
Input Format
A string str
Output Format
count of subsequences of the nature a+b+c+
Constraints
0 < str.length <= 10
Sample Input
abcabc
Sample Output
7
Solution:
import java.io.*;
import java.util.*;
public class Main {
public static void main(String[] args) throws Exception {
// in
Scanner sc = new Scanner(System.in);
String str = sc.nextLine();
sc.close();
// process
int a = 0, ab = 0, abc = 0, n = str.length();
for(int i=0;i<n;i++){
char ch = str.charAt(i);
if(ch == 'a')
a = 2*a + 1;
else if(ch == 'b')
ab = 2*ab+a;
else if(ch == 'c')
abc = 2*abc+ab;
}
System.out.println(abc);
}
}
Comments
Post a Comment