Skip to main content

Paint House - Many Colors

1. You are given a number n and a number k separated by a space, representing the number of houses and number of colors.

2. In the next n rows, you are given k space separated numbers representing the cost of painting nth house with one of the k colors.

3. You are required to calculate and print the minimum cost of painting all houses without painting any consecutive house with same color.

Input Format

A number n

n1-0th n1-1st n1-2nd .. n1-kth

n2-0th n2-1st n2-2nd .. n2-kth

.. n number of elements

Output Format

A number representing the minimum cost of painting all houses without painting any consecutive house with same color.

Constraints

1 <= n <= 1000

1 <= k <= 10

0 <= n1-0th, n1-1st, .. <= 1000

Sample Input

4 3

1 5 7

5 8 4

3 2 9

1 2 4

Sample Output

8


Solution

import java.io.*;

import java.util.*;


public class Main {


    public static void main(String[] args) throws Exception {

        // input

        Scanner sc = new Scanner(System.in);

        int n = sc.nextInt(), m = sc.nextInt();

        int[][] A = new int[n][m];

        

        for(int i=0;i<n;i++)

            for(int j=0;j<m;j++)

                A[i][j] = sc.nextInt();

        

        int color[] = new int[m];

        

        for(int i=0;i<n;i++){

            int col[] = new int[m];

            for(int j=0;j<m;j++){

                int min = Integer.MAX_VALUE;

                for(int c=1;c<m;c++){

                    min = Math.min(min,color[(j+c)%m]);

                }

                col[j] = A[i][j] + min;

            }

            color = col;

        }

        

        int min = color[0];

        for(int c=1;c<m;c++)

            min = Math.min(min,color[c]);

        System.out.println(min);

    }

}

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Classes and Objects, Packages | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text State True or False When using eclipse whichever classes are needed for the present class can be imported automatically. Select one: True   False Feedback The correct answer is 'True'. Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text switch(a) {     default:         System.out.println("Welcome"); } Of which data types can the variable ‘a’ be? 1. long 2. byte 3. int 4. char 5. float 6. short Select one: 3, 4 and 5 1 and 3 3 and 4 2,3, 4 and 6   Feedback Your answer is correct. The variable used in a switch statement can be a byte, short, int, char or String type only. The correct answer is:  2,3, 4 and 6 Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Predict the output.   public class Test {         public static void main(String args[])         {                     int a = 2, b = 0;              for ( ; b < 20; ++b) {                  if (b % a == 0)

Balanced Brackets

1. You are given a string exp representing an expression. 2. You are required to check if the expression is balanced i.e. closing brackets and opening brackets match up well. e.g. [(a + b) + {(c + d) * (e / f)}] -> true [(a + b) + {(c + d) * (e / f)]} -> false [(a + b) + {(c + d) * (e / f)} -> false ([(a + b) + {(c + d) * (e / f)}] -> false Input Format A string str Output Format true or false Constraints 0 <= str.length <= 100 Sample Input [(a + b) + {(c + d) * (e / f)}] Sample Output true Solution import java.io.*; import java.util.*; public class Main {     public static void main(String[] args) throws Exception {         Scanner sc = new Scanner(System.in);         String str = sc.nextLine();         int n = str.length();         Stack<Character> s = new Stack<>();         for(int i=0;i<n;i++){             char ch = str.charAt(i);             if(ch == '[')                 s.push(']');             else if(ch == '{'