Skip to main content

Paint House - Many Colors

1. You are given a number n and a number k separated by a space, representing the number of houses and number of colors.

2. In the next n rows, you are given k space separated numbers representing the cost of painting nth house with one of the k colors.

3. You are required to calculate and print the minimum cost of painting all houses without painting any consecutive house with same color.

Input Format

A number n

n1-0th n1-1st n1-2nd .. n1-kth

n2-0th n2-1st n2-2nd .. n2-kth

.. n number of elements

Output Format

A number representing the minimum cost of painting all houses without painting any consecutive house with same color.

Constraints

1 <= n <= 1000

1 <= k <= 10

0 <= n1-0th, n1-1st, .. <= 1000

Sample Input

4 3

1 5 7

5 8 4

3 2 9

1 2 4

Sample Output

8


Solution

import java.io.*;

import java.util.*;


public class Main {


    public static void main(String[] args) throws Exception {

        // input

        Scanner sc = new Scanner(System.in);

        int n = sc.nextInt(), m = sc.nextInt();

        int[][] A = new int[n][m];

        

        for(int i=0;i<n;i++)

            for(int j=0;j<m;j++)

                A[i][j] = sc.nextInt();

        

        int color[] = new int[m];

        

        for(int i=0;i<n;i++){

            int col[] = new int[m];

            for(int j=0;j<m;j++){

                int min = Integer.MAX_VALUE;

                for(int c=1;c<m;c++){

                    min = Math.min(min,color[(j+c)%m]);

                }

                col[j] = A[i][j] + min;

            }

            color = col;

        }

        

        int min = color[0];

        for(int c=1;c<m;c++)

            min = Math.min(min,color[c]);

        System.out.println(min);

    }

}

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the ...

UPSEE Counselling 2018 Round 3

UPSEE Counselling 2018 Round 3, AKTU/UPTU Counselling, Started – Register Here UPSEE 2018 Seat Allotment Result (Round 3)  is releasing on  13th July 2018 . It will be conducted through online mode. The university conducts a state level examination in name of Uttar Pradesh State Entrance Exam (UPSEE) for providing admission to the UG & PG courses in the field of engineering, management, etc.  You can get complete information about AKTU Counselling 2018. Here, we are providing details about the schedule, procedure, admission, etc. UPSEE Counselling 2018 –  Seat Allotment Round 2 Result on 10th July Exclusive:  UPSEE 2018 Seat Allotment Result (Round 3) is releasing on 17th July 2018.  Link will be provided here. UPSEE 2018 Counselling User Manual for candidates has been released now.   Click here to view user manual. Click here to view UPSEE 2018 Counselling schedule. Physical reporting will be started on 20th July....

Spot Round

Never ever give up !!! “Life is a journey with up and downs” Feeling happy when everything is right is natural, but feeling sad for something gone wrong can’t be justified. Many say miracle doesn’t happen, but a miracle is something that doesn’t have logic… Do you believe in miracles? So, stop seeing logic everywhere and then you can feel miracles. I want to share something… During my counselling for Bachelor’s degree till last round, I was unable to get a seat in college I want to study in. It felt like everything has gone. Then I heard about Spot Round. I was not sure to secure a seat. But I went there to try my luck, in a hope of a miracle. So, I kept ready all my necessary documents made a DD for this round. While I was going to reporting centre my mind was full of the variety of thoughts. I made a mistake and I was little late for reporting. So, I rushed up through check-in and register myself for this special round. Then I went to a hall where everyone ...