Skip to main content

Tower Of Hanoi

 1. There are 3 towers. Tower 1 has n disks, where n is a positive number. Tower 2 and 3 are empty.

2. The disks are increasingly placed in terms of size such that the smallest disk is on top and largest disk is at bottom.
3. You are required to
3.1. Print the instructions to move the disks.
3.2. from tower 1 to tower 2 using tower 3
3.3. following the rules
3.3.1 move 1 disk at a time.
3.3.2 never place a smaller disk under a larger disk.
3.3.3 you can only move a disk at the top.

Note -> The online judge can't force you to write the function recursively but that is what the spirit of question is.Write recursive and not iterative logic. The purpose of the question is to aid learning recursion and not test you.
Input Format
A number n, representing number of disks
A number n1, representing id of tower 1
A number n2, representing id of tower 2
A number n3, representing id of tower 3
Output Format
n[n1 -> n2] 
..
A set of instructions in above format to represent, move nth disc from n1 tower to n2 tower
Constraints
0 <= n <= 9
10 <= n1, n2, n3 <= 10^9
n1 != n2 != n3
Sample Input
3
10
11
12
Sample Output
1[10 -> 11]
2[10 -> 12]
1[11 -> 12]
3[10 -> 11]
1[12 -> 10]
2[12 -> 11]
1[10 -> 11]

Solution:

import java.io.*;
import java.util.*;

public class Main {

    public static void main(String[] args) throws Exception {
        // write your code here
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        int t1 = sc.nextInt(), t2 = sc.nextInt(), t3 = sc.nextInt();
        toh(n,t1,t2,t3);
    }

    public static void toh(int n, int t1id, int t2id, int t3id){
        if(n == 0) return;
        toh(n-1,t1id,t3id,t2id);
        System.out.println(n+"["+t1id+" -> "+t2id+"]");
        toh(n-1,t3id,t2id,t1id);
    }

}

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the ...

UPSEE Counselling 2018 Round 3

UPSEE Counselling 2018 Round 3, AKTU/UPTU Counselling, Started – Register Here UPSEE 2018 Seat Allotment Result (Round 3)  is releasing on  13th July 2018 . It will be conducted through online mode. The university conducts a state level examination in name of Uttar Pradesh State Entrance Exam (UPSEE) for providing admission to the UG & PG courses in the field of engineering, management, etc.  You can get complete information about AKTU Counselling 2018. Here, we are providing details about the schedule, procedure, admission, etc. UPSEE Counselling 2018 –  Seat Allotment Round 2 Result on 10th July Exclusive:  UPSEE 2018 Seat Allotment Result (Round 3) is releasing on 17th July 2018.  Link will be provided here. UPSEE 2018 Counselling User Manual for candidates has been released now.   Click here to view user manual. Click here to view UPSEE 2018 Counselling schedule. Physical reporting will be started on 20th July....

Display of Provisional Answer Keys and Question Paper with Recorded Responses for Answer Key Challenge | JEE (Main) 2021 Session 4 for Paper 1 (B.E./B.Tech.)

The JEE (Main) - 2021 Session - 4 was conducted throughout the country and abroad on 26, 27, 31 August and 1 September 2021 for Paper 1 (B.E./B.Tech.) in the Computer Based Test (CBT) mode. The National Testing Agency has uploaded the Provisional Answer Keys for Paper 1 (B.E./B.Tech.) along with the Question Paper with Recorded Responses on the website https://jeemain.nta.nic.in for candidates to challenge. The procedure (as enclosed) for the challenge of Answer Key may be used. The candidates, who are not satisfied with the answer key, may challenge the same by paying a fee of ₹ 200/- (Rupees Two Hundred only) per question challenged as a non-refundable processing fee. This facility is available from 06 September 2021 to 08 September 2021 (up to 10:00 A.M.). The payment of the processing fee may be made through, Debit card/Credit Card/Net Banking/Paytm upto 08 September 2021 (upto 11:00 A.M.). No challenge will be entertained without receipt of the processing fee. The Challenges will ...