Skip to main content

Test Match Series Problem Code: TESTSERIES | SnackDown 2021 - Online Qualifiers

 match test series between India and England has just concluded.

Every match could have ended either as a win for India, a win for England, or a draw. You know the result of all the matches. Determine who won the series or if it ended in a draw.

A team is said to have won the series if it wins strictly more test matches than the other team.

Input Format

  • First-line will contain T, the number of test cases. Then the test cases follow.
  • Each test case contains a single line of input, five space-separated integers R1,R2,R3,R4,R5 denoting the results of all the five matches. Ri=0 denotes that the test match ends in a draw. Ri=1 denotes that the test match is won by India. Ri=2 denotes that the test match is won by England.

Output Format

For each test output "DRAW" if the series ends in a draw, "INDIA" if the series is won by India, and "ENGLAND" if the series is won by England.

You may print each character of the string in uppercase or lowercase (for example, the strings "dRaw", "draw", "Draw" and "DRAW" will all be treated as identical).

Constraints

  • 1T1000
  • 0Ri2

Sample Input 1 

3
0 1 2 1 0
0 1 2 1 2
2 2 2 2 1

Sample Output 1 

INDIA
DRAW
ENGLAND

Explanation

Test Case : India wins 2 matches while England won 1 match so India wins the series.

Test Case : Both teams win 2 matches so the series ends in a draw.

Test Case : England won 4 matches while India won 1 match so England wins the series.

 

Solution:


import java.util.*;
import java.lang.*;
import java.io.*;


class Codechef
{
public static void main (String[] args) throws java.lang.Exception
{
// your code goes here
Scanner sc = new Scanner(System.in);
int t = sc.nextInt();
while(t-- != 0){
    int e = 0, wI = 0, wA = 0;
    for(int i=0;i<5;i++){
        e = sc.nextInt();
        if(e == 1)
            ++wI;
        else if(e == 2)
            ++wA;
    }
    if(wI == wA)
        System.out.println("DRAW");
    else if(wI>wA){
        System.out.println("INDIA");
    }else System.out.println("ENGLAND");
}
sc.close();
}
}

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the ...

UPSEE Counselling 2018 Round 3

UPSEE Counselling 2018 Round 3, AKTU/UPTU Counselling, Started – Register Here UPSEE 2018 Seat Allotment Result (Round 3)  is releasing on  13th July 2018 . It will be conducted through online mode. The university conducts a state level examination in name of Uttar Pradesh State Entrance Exam (UPSEE) for providing admission to the UG & PG courses in the field of engineering, management, etc.  You can get complete information about AKTU Counselling 2018. Here, we are providing details about the schedule, procedure, admission, etc. UPSEE Counselling 2018 –  Seat Allotment Round 2 Result on 10th July Exclusive:  UPSEE 2018 Seat Allotment Result (Round 3) is releasing on 17th July 2018.  Link will be provided here. UPSEE 2018 Counselling User Manual for candidates has been released now.   Click here to view user manual. Click here to view UPSEE 2018 Counselling schedule. Physical reporting will be started on 20th July....

Spot Round

Never ever give up !!! “Life is a journey with up and downs” Feeling happy when everything is right is natural, but feeling sad for something gone wrong can’t be justified. Many say miracle doesn’t happen, but a miracle is something that doesn’t have logic… Do you believe in miracles? So, stop seeing logic everywhere and then you can feel miracles. I want to share something… During my counselling for Bachelor’s degree till last round, I was unable to get a seat in college I want to study in. It felt like everything has gone. Then I heard about Spot Round. I was not sure to secure a seat. But I went there to try my luck, in a hope of a miracle. So, I kept ready all my necessary documents made a DD for this round. While I was going to reporting centre my mind was full of the variety of thoughts. I made a mistake and I was little late for reporting. So, I rushed up through check-in and register myself for this special round. Then I went to a hall where everyone ...