Skip to main content

Partition Into Subsets

1. You are given a number n, representing the number of elements.

2. You are given a number k, representing the number of subsets.

3. You are required to print the number of ways in which these elements can be partitioned in k non-empty subsets.

E.g.

For n = 4 and k = 3 total ways is 6

12-3-4

1-23-4

13-2-4

14-2-3

1-24-3

1-2-34

Input Format

A number n

A number k

Output Format

A number representing the number of ways in which these elements can be partitioned in k non-empty subsets.


Constraints

0 <= n <= 20

0 <= k <= n

Sample Input

4

3

Sample Output

6

Solution: 

import java.io.*;

import java.util.*;


public class Main {

        

    public static long partitionKSubset(int n, int k) {

        // write your code here

        if(n == 0 || k==0 || n<k) return 0;

        

        long dp[][] = new long[k+1][n+1];

        

        for(int i=1;i<=k;i++){

            for(int j=1;j<=n;j++){

                if(i==1)

                    dp[i][j] = 1;

                else if(i==j)

                    dp[i][j] = 1;

                else if(j>i) {

                    dp[i][j] = (i * dp[i][j-1]) + dp[i-1][j-1];

                }

                // System.out.print(dp[i][j]+" ");

            }

            // System.out.println();

        }

        return dp[k][n];

    }

   

    public static void main(String[] args) throws Exception {

        Scanner scn = new Scanner(System.in);

        int n = scn.nextInt();

        int k = scn.nextInt();

        

        long res = partitionKSubset(n, k);

        System.out.println(res);

    }

}

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Classes and Objects, Packages | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text State True or False When using eclipse whichever classes are needed for the present class can be imported automatically. Select one: True   False Feedback The correct answer is 'True'. Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text switch(a) {     default:         System.out.println("Welcome"); } Of which data types can the variable ‘a’ be? 1. long 2. byte 3. int 4. char 5. float 6. short Select one: 3, 4 and 5 1 and 3 3 and 4 2,3, 4 and 6   Feedback Your answer is correct. The variable used in a switch statement can be a byte, short, int, char or String type only. The correct answer is:  2,3, 4 and 6 Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Predict the output.   public class Test {         public static void main(String args[])         {                     int a = 2, b = 0;              for ( ; b < 20; ++b) {                  if (b % a == 0)

Balanced Brackets

1. You are given a string exp representing an expression. 2. You are required to check if the expression is balanced i.e. closing brackets and opening brackets match up well. e.g. [(a + b) + {(c + d) * (e / f)}] -> true [(a + b) + {(c + d) * (e / f)]} -> false [(a + b) + {(c + d) * (e / f)} -> false ([(a + b) + {(c + d) * (e / f)}] -> false Input Format A string str Output Format true or false Constraints 0 <= str.length <= 100 Sample Input [(a + b) + {(c + d) * (e / f)}] Sample Output true Solution import java.io.*; import java.util.*; public class Main {     public static void main(String[] args) throws Exception {         Scanner sc = new Scanner(System.in);         String str = sc.nextLine();         int n = str.length();         Stack<Character> s = new Stack<>();         for(int i=0;i<n;i++){             char ch = str.charAt(i);             if(ch == '[')                 s.push(']');             else if(ch == '{'