Skip to main content

Accenture Mock Quiz | Part 3

 

Question 21

Correct
Marked out of 1.00
Flag question

Question text

Identify the predicate which selects the last Employee element that is the child of the Company element?


Select one:
 

Feedback

Question 22

Incorrect
Marked out of 1.00
Flag question

Question text

Find out the well-formed xml file

Select one:
 

Feedback

Question 23

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

public class ApplicationTester 
{
public static void main(String[] args)
{
int i=0;
for(i=0; i<10; i++)
{
if(i == 5)
{
continue;
}
i++;
System.out.print(i + " ");
}
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Question 24

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

class StringSample 
{
public StringSample(String string)
{
System.out.println("The string is " + string);
}
}
public class ConstructorTester1
{
public static void main(String[] args)
{
StringSample stringSample = new StringSample();
StringSample stringSample1 = new StringSample("Test String");
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Question 25

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

 public class Rectangle 
{
private int length;
private int width;
public static void main(String[] args)
{
Rectangle rectangle1 = new Rectangle();
rectangle1.length=10;
rectangle1.width=5;
Rectangle rectangle2 = rectangle1;
System.out.println("Length : "+rectangle2.length);
System.out.println("Width : "+rectangle2.width);
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Question 26

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

 public class MyClass 
{
private static int data;
static
{
MyClass.data = 999;
}
public static int getData()
{
return data;
}
public static void setData(int data)
{
MyClass.data = data;
}
}
public class ApplicationTester
{
public static void main(String[] args)
{
MyClass ref1 = new MyClass();
MyClass ref2 = new MyClass();
System.out.print(ref1.getData());
ref2.setData(111);
System.out.println(" " + ref1.getData());
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Question 27

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

 class Event
{
static int eventId;
public static void main(String[] args)
{
Event e1=new Event();
e1.eventId=100;
Event e2=e1; e2.eventId=200;
Event e3=new Event();
System.out.println(e1.eventId+ " "+ e2.eventId + " "+ e3.eventId);
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Question 28

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

 public class Vehicle 
{
protected String enginePower;
public Vehicle()
{
this.enginePower = "100CC";
}
public String getEnginePower()
{
return this.enginePower;
}
}
public class PassengerVehicle extends Vehicle
{
private int capacity;
public PassengerVehicle()
{
this.capacity = 50;
this.enginePower = "150CC";
}
public int getCapacity()
{
return this.capacity;
}
}
public class ApplicationTester
{
public static void main(String[] args)
{
Vehicle vehicle = new PassengerVehicle();
System.out.println(vehicle.getEnginePower());
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Question 29

Correct
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?


public class ApplicationTester {

           public static void main(String[] args) {

                 int [] array1 = {10,20,30,40,50};

                 int [] array2 = array1;

                 for(int index1=0,index2=3; index2<array2.length&&index1<array1.length; index1++,++index2)

                   {

                                array1[index1]++;

                                System.out.print(array2[index2]+” ”);

                   }

         }

}


Select one:
 

Feedback

Question 30

Incorrect
Marked out of 1.00
Flag question

Question text

What will be the output of the following Java code?

 
public class ApplicationTester
{
public static void main(String[] args)
{
int[] array = {-9,-11-8,-100,-78};
int minimum = 0;
for(int index=0; index < array.length; index++)
{
if(minimum < array[index])
{ minimum = array[index];
}
}
System.out.println(minimum);
}
}
Choose the most appropriate option.

Select one:
 

Feedback

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Classes and Objects, Packages | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text State True or False When using eclipse whichever classes are needed for the present class can be imported automatically. Select one: True   False Feedback The correct answer is 'True'. Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text switch(a) {     default:         System.out.println("Welcome"); } Of which data types can the variable ‘a’ be? 1. long 2. byte 3. int 4. char 5. float 6. short Select one: 3, 4 and 5 1 and 3 3 and 4 2,3, 4 and 6   Feedback Your answer is correct. The variable used in a switch statement can be a byte, short, int, char or String type only. The correct answer is:  2,3, 4 and 6 Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Predict the output.   public class Test {         public static void main(String args[])         {                     int a = 2, b = 0;              for ( ; b < 20; ++b) {                  if (b % a == 0)

Balanced Brackets

1. You are given a string exp representing an expression. 2. You are required to check if the expression is balanced i.e. closing brackets and opening brackets match up well. e.g. [(a + b) + {(c + d) * (e / f)}] -> true [(a + b) + {(c + d) * (e / f)]} -> false [(a + b) + {(c + d) * (e / f)} -> false ([(a + b) + {(c + d) * (e / f)}] -> false Input Format A string str Output Format true or false Constraints 0 <= str.length <= 100 Sample Input [(a + b) + {(c + d) * (e / f)}] Sample Output true Solution import java.io.*; import java.util.*; public class Main {     public static void main(String[] args) throws Exception {         Scanner sc = new Scanner(System.in);         String str = sc.nextLine();         int n = str.length();         Stack<Character> s = new Stack<>();         for(int i=0;i<n;i++){             char ch = str.charAt(i);             if(ch == '[')                 s.push(']');             else if(ch == '{'