Skip to main content

Arrays and Strings | Accenture TFA

 

Question 1

Correct
Mark 1.00 out of 1.00
Flag question

Question text

Which members of a class can be accessed by other classes is determined by the ________________

Select one:
 

Feedback

Question 2

Correct
Mark 1.00 out of 1.00
Flag question

Question text

Predict the Output of following Java Program.

class Test {

    int x  = 10;  

    public static void main(String[] args) {    

         System.out.println(x);

    }

}

Select one:
 

Feedback

Question 3

Correct
Mark 1.00 out of 1.00
Flag question

Question text

Identify the true statement(s).

Statement 1 : When no constructor is written in a class, the compiler creates a default constructor

Statement 2 : The default constructor will implicitly invoke the default / no-argument constructor of the super class

Statement 3 : If  a class has a parametrized constructor alone, then the compiler will create the default constructor

Statement 4  :  If a class has a parametrized constructor, it is mandatory to write a no-argument constructor


Select one:
 

Feedback

Question 4

Correct
Mark 1.00 out of 1.00
Flag question

Question text

What does this() mean in constructor chaining concept?

Select one:
 

Feedback

Question 5

Correct
Mark 1.00 out of 1.00
Flag question

Question text

Given:
public class ItemTest 

private final int id; 
public ItemTest(int id) {
this.id = id;
}
public void updateId(int newId)  { 
id = newId; 

public static void main(String[] args)  { 
ItemTest fa = new ItemTest(42); 
fa.updateId(69); 
System.out.println(fa.id); 

}
What is the result?


Select one:
 

Feedback

Question 6

Correct
Mark 1.00 out of 1.00
Flag question

Question text

A JavaBeans component has the following field:

private boolean enabled;

Which two pairs of method declarations follow the JavaBeans standard for accessing this field? (Choose two.)

Select one or more:
 
 

Feedback

Question 7

Correct
Mark 1.00 out of 1.00
Flag question

Question text

package edu.ABC.model; 

public class Account  {

         public static final float INTERTEST_RATE = 7.5;

}


Identify the correct options from the classes provided below.

Select one or more:
 
 

Feedback

Question 8

Correct
Mark 1.00 out of 1.00
Flag question

Question text

Identify which statement is true about construtors.


Select one:
 

Feedback

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Classes and Objects, Packages | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text State True or False When using eclipse whichever classes are needed for the present class can be imported automatically. Select one: True   False Feedback The correct answer is 'True'. Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text switch(a) {     default:         System.out.println("Welcome"); } Of which data types can the variable ‘a’ be? 1. long 2. byte 3. int 4. char 5. float 6. short Select one: 3, 4 and 5 1 and 3 3 and 4 2,3, 4 and 6   Feedback Your answer is correct. The variable used in a switch statement can be a byte, short, int, char or String type only. The correct answer is:  2,3, 4 and 6 Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Predict the output.   public class Test {         public static void main(String args[])         {                     int a = 2, b = 0;              for ( ; b < 20; ++b) {                  if (b % a == 0)

Balanced Brackets

1. You are given a string exp representing an expression. 2. You are required to check if the expression is balanced i.e. closing brackets and opening brackets match up well. e.g. [(a + b) + {(c + d) * (e / f)}] -> true [(a + b) + {(c + d) * (e / f)]} -> false [(a + b) + {(c + d) * (e / f)} -> false ([(a + b) + {(c + d) * (e / f)}] -> false Input Format A string str Output Format true or false Constraints 0 <= str.length <= 100 Sample Input [(a + b) + {(c + d) * (e / f)}] Sample Output true Solution import java.io.*; import java.util.*; public class Main {     public static void main(String[] args) throws Exception {         Scanner sc = new Scanner(System.in);         String str = sc.nextLine();         int n = str.length();         Stack<Character> s = new Stack<>();         for(int i=0;i<n;i++){             char ch = str.charAt(i);             if(ch == '[')                 s.push(']');             else if(ch == '{'