1. You are given a number n1, representing the size of array a1.
2. You are given n1 numbers, representing elements of array a1.Input Format
3. You are given a number n2, representing the size of array a2.
4. You are given n2 numbers, representing elements of array a2.
5. The two arrays represent digits of two numbers.
6. You are required to add the numbers represented by two arrays and print the
arrays.
A number n1Output Format
n1 number of elements line separated
A number n2
n2 number of elements line separated
A number representing sum of two numbers, represented by two arrays.
Constraints
1 <= n1, n2 <= 100
0 <= a1[i], a2[i] < 10
Sample Input
5
3
1
0
7
5
6
1
1
1
1
1
1
Sample Output
1
4
2
1
8
6
import java.io.*;
import java.util.*;
public class Main{
public static void main(String[] args) throws Exception {
// write your code here
Scanner scn = new Scanner(System.in);
int n1=scn.nextInt();
int[] arr1 = new int[n1];
for(int i=0;i<n1;i++)
arr1[i] = scn.nextInt();
int n2=scn.nextInt();
int[] arr2 = new int[n2];
for(int i=0;i<n2;i++)
arr2[i] = scn.nextInt();
int[] arr = new int[n1>n2 ? n1:n2];
int k = arr.length-1,c=0;
--n1; --n2;
while(k>=0){
int d = c;
if(n1>=0)
d+= arr1[n1];
if(n2>=0)
d+=arr2[n2];
c = d/10;
d = d%10;
arr[k] = d;
--k;
--n1;
--n2;
}
if(c!=0)
System.out.println(c);
for(int x:arr)
System.out.println(x);
}
}
Comments
Post a Comment