Skip to main content

Buffered Reader | InterviewBit

Problem Description

The BufferedReader class of Java is used to read the stream of characters from the specified source (character-input stream). The constructor of this class accepts an InputStream object as a parameter

This class provides a method named read() and readLine() which reads and returns the character and next line from the source (respectively) and returns them.

  • Instantiate an InputStreamReader class bypassing your InputStream object as a parameter.
  • Then, create a BufferedReader, bypassing the above obtained InputStreamReader object as a parameter.
  • Now, read data from the current reader as String using the readLine() or read() method.
  • For Example: Suppose we want to read an integer from the user then the code will look like:

     BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
     int toRead = Integer.parseInt(reader.readLine());
    

    Another Example: Suppose we want to read a line (in form of a string) from the user then the code will look like:

     BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
     String toRead = reader.readLine();
    

    References: Click Here

    Task:

    Their exist two lines of input each consist of single integer, read these two integers using BufferedReader Class and then print both of them on a single line in a space-separated manner.



    Input Format

    Input consist of two lines.

    Both of the lines contains a single integer.



    Output Format

    Print both of the integers on a single line in a space-separated manner.



    Example Input

    Input 1:

     12
     1
    

    Input 2:

     12
     110
    



    Example Output

    Output 1:

     12 1
    

    Output 2:

     12 110
    

    Solution: 

    import java.lang.*;
    import java.util.*;
    import java.io.BufferedReader;
    import java.io.IOException;
    import java.io.InputStreamReader;
    public class Main {
        public static void main(String[] args) throws IOException {
            
            //your code goes here
            BufferedReader breader = new BufferedReader(new InputStreamReader(System.in));

            int a = Integer.parseInt(breader.readLine());
            int b= Integer.parseInt(breader.readLine());

            System.out.println(a+" "+b);
        }

    } 




    Comments

    Popular posts from this blog

    Classes and Objects | Accenture TFA

      Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

    Spot Round

    Never ever give up !!! “Life is a journey with up and downs” Feeling happy when everything is right is natural, but feeling sad for something gone wrong can’t be justified. Many say miracle doesn’t happen, but a miracle is something that doesn’t have logic… Do you believe in miracles? So, stop seeing logic everywhere and then you can feel miracles. I want to share something… During my counselling for Bachelor’s degree till last round, I was unable to get a seat in college I want to study in. It felt like everything has gone. Then I heard about Spot Round. I was not sure to secure a seat. But I went there to try my luck, in a hope of a miracle. So, I kept ready all my necessary documents made a DD for this round. While I was going to reporting centre my mind was full of the variety of thoughts. I made a mistake and I was little late for reporting. So, I rushed up through check-in and register myself for this special round. Then I went to a hall where everyone

    Certificates Format JoSAA 2018

    Certificates Format JoSAA 2018 JoSAA certificate formats  required at time of documents verification at reporting centres are released and must download them from here... Click the  JoSAA certificate formats  and you will get the certificate you want for JoSAA. You can download required formats from this page. Do check for these documents before leaving your place... Click here to get the checklist for JoSAA counselling documents verification... Know more about first-round result 2018... Certificates Format JoSAA 2018 Format for Document Verification For admission to IITs and ISM The format for Document Verification For admission to IITs and ISM is given below. You will have to follow this pattern for JoSAA document Verification, click here to download... Format for Document Verification For admission to NITs, IIITs and Other-GFTIs For admission to NITs, IIITs and Other-GFTIs candidates will have to verify their documents and here is the format