1. You are given a number n1, representing the size of array a1.
2. You are given n1 numbers, representing elements of array a1.Input Format
3. You are given a number n2, representing the size of array a2.
4. You are given n2 numbers, representing elements of array a2.
5. The two arrays represent digits of two numbers.
6. You are required to find the difference of two numbers represented by two arrays and print the arrays. a2 - a1
Assumption - number represented by a2 is greater.
A number n1Output Format
n1 number of elements line separated
A number n2
n2 number of elements line separated
A number representing difference of two numbers (a2 - a1), represented by two arrays.
Constraints
1 <= n1, n2 <= 100
0 <= a1[i], a2[i] < 10
number reresented by a1 is smaller than number represented by a2
Sample Input
3
2
6
7
4
1
0
0
0
Sample Output
7
3
3
import java.io.*;
import java.util.*;
public class Main{
public static void main(String[] args) throws Exception {
// write your code here
Scanner scn = new Scanner(System.in);
int n1 = scn.nextInt();
int[] arr1 = new int[n1];
for(int i=0;i<n1;i++)
arr1[i] = scn.nextInt();
int n2 = scn.nextInt();
int[] arr2 = new int[n2];
for(int i=0;i<n2;i++)
arr2[i] = scn.nextInt();
int[] arr = new int[n2];
int i=n2-1,j=n1-1,c=0;
while(i>=0){
int d = 0;
int a1v = j>=0 ? arr1[j] : 0;
if(arr2[i]+c>=a1v){
d = arr2[i] + c - a1v;
c=0;
}else{
d = arr2[i] + c + 10 - a1v;
c=-1;
}
arr[i] = d;
--i;
--j;
}
for(i=0;i<arr.length;i++)
if(arr[i]!=0)
break;
for(;i<arr.length;i++)
System.out.println(arr[i]);
}
}
Comments
Post a Comment