Skip to main content

Java Flow Control And Functions If Else | Day 1

Problem:

In computer programming, we use the if statement to control the flow of the program. For example, if a certain condition is met, then run a specific block of code. Otherwise, run another code.

For example:

 class Main {
public static void main(String[] args) {

int number = 0;

// checks if number is greater than 0
if (number > 0) {
System.out.println("The number is positive.");
}

// checks if number is less than 0
else if (number < 0) {
System.out.println("The number is negative.");
}

// if both condition is false
else {
System.out.println("The number is 0.");
}
}
}


Output

The number is 0.

In the above example, we are checking whether the number is positive, negative, or zero.

Here, we have two condition expressions:

  • number > 0 - checks if the number is greater than 0
  • number < 0 - checks if the number is less than 0

Here, the value of the number is 0. So both the conditions evaluate to false. Hence the statement inside the body of else is executed.

Task:

Given an integer M perform the following conditional actions:

  • If M is multiple of 3 and 5 then print "Good Number" (without quotes).
  • If M is only multiple of 3 and not of 5 then print "Bad Number" (without quotes).
  • If M is only multiple of 5 and not of 3 then print "Poor Number" (without quotes).
  • If M doesn't satisfy any of the above conditions then print "-1" (without quotes).

 

Solution:

import java.lang.*;
import java.util.*;

public class Main {
    public static void main(String[] args) {
        /***Don't change the code here***/
        
        Scanner inp  = new Scanner(System.in);
        int M = inp.nextInt();
        inp.close();
        /*********************************/
        
        /**Write your code here**/
        
        if(M%3==0 && M%5==0){
            System.out.println("Good Number");
        }else if(M%3==0)
            System.out.println("Bad Number");
        else if(M%5==0)
            System.out.println("Poor Number");
        else 
            System.out.println(-1);
    }
}

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Classes and Objects, Packages | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text State True or False When using eclipse whichever classes are needed for the present class can be imported automatically. Select one: True   False Feedback The correct answer is 'True'. Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text switch(a) {     default:         System.out.println("Welcome"); } Of which data types can the variable ‘a’ be? 1. long 2. byte 3. int 4. char 5. float 6. short Select one: 3, 4 and 5 1 and 3 3 and 4 2,3, 4 and 6   Feedback Your answer is correct. The variable used in a switch statement can be a byte, short, int, char or String type only. The correct answer is:  2,3, 4 and 6 Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Predict the output.   public class Test {         public static void main(String args[])         {                     int a = 2, b = 0;              for ( ; b < 20; ++b) {                  if (b % a == 0)

Balanced Brackets

1. You are given a string exp representing an expression. 2. You are required to check if the expression is balanced i.e. closing brackets and opening brackets match up well. e.g. [(a + b) + {(c + d) * (e / f)}] -> true [(a + b) + {(c + d) * (e / f)]} -> false [(a + b) + {(c + d) * (e / f)} -> false ([(a + b) + {(c + d) * (e / f)}] -> false Input Format A string str Output Format true or false Constraints 0 <= str.length <= 100 Sample Input [(a + b) + {(c + d) * (e / f)}] Sample Output true Solution import java.io.*; import java.util.*; public class Main {     public static void main(String[] args) throws Exception {         Scanner sc = new Scanner(System.in);         String str = sc.nextLine();         int n = str.length();         Stack<Character> s = new Stack<>();         for(int i=0;i<n;i++){             char ch = str.charAt(i);             if(ch == '[')                 s.push(']');             else if(ch == '{'