Skip to main content

Classes and Objects, Packages | Accenture TFA

 

Question 1

Correct
Mark 1.00 out of 1.00
Flag question

Question text

State True or False

When using eclipse whichever classes are needed for the present class can be imported automatically.

Select one:
 

Feedback

Question 2

Correct
Mark 1.00 out of 1.00
Flag question

Question text

switch(a)

{

    default:

        System.out.println("Welcome");

}

Of which data types can the variable ‘a’ be?

1. long

2. byte

3. int

4. char

5. float

6. short

Select one:
 

Feedback

Question 3

Correct
Mark 1.00 out of 1.00
Flag question

Question text

Predict the output.

 

public class Test {

        public static void main(String args[])

        {       

             int a = 2, b = 0;

             for ( ; b < 20; ++b) {

                 if (b % a == 0)

                     continue; 

                 else if (b == 10)

                      break;

                 else

                    System.out.print(b + " ");

             }

        }

 }

Select one:
 

Feedback

Question 4

Correct
Mark 1.00 out of 1.00
Flag question

Question text

What will be the output of the following code?

 

int i=20;

if(i>10)

{

      System.out.println( "The value of i is "+i);

      i++;

      if(i%2!=0)

          break;


Select one:
 

Feedback

Question 5

Correct
Mark 1.00 out of 1.00
Flag question

Question text

In Eclipse IDE, if we provide a workspace, it should already exist.  If not, it will not open.

Select one:
 

Feedback

Comments

Popular posts from this blog

Classes and Objects | Accenture TFA

  Question  1 Correct Mark 1.00 out of 1.00 Flag question Question text ___ and _____ are the access specifiers that can be applied to top level Class. Select one or more: public   protected default   private Feedback Your answer is correct. The correct answers are: default, public Question  2 Correct Mark 1.00 out of 1.00 Flag question Question text class Sample{      private double num = 100;    private int square(int a){ return a*a;    } }   public class Test{    public static void main(String args[]){   Sample obj = new Sample();   System.out.println(obj.num);  System.out.println(obj.square(10));    }   } Select one: Compile time error   Run time error Executes but no output 100 Feedback Your answer is correct. The correct answer is: Compile time error Question  3 Correct Mark 1.00 out of 1.00 Flag question Question text Choose the appropriate access specifier for the attribute value so that it can be accessed from anywhere. class Test { Choose... private protected public d

Balanced Brackets

1. You are given a string exp representing an expression. 2. You are required to check if the expression is balanced i.e. closing brackets and opening brackets match up well. e.g. [(a + b) + {(c + d) * (e / f)}] -> true [(a + b) + {(c + d) * (e / f)]} -> false [(a + b) + {(c + d) * (e / f)} -> false ([(a + b) + {(c + d) * (e / f)}] -> false Input Format A string str Output Format true or false Constraints 0 <= str.length <= 100 Sample Input [(a + b) + {(c + d) * (e / f)}] Sample Output true Solution import java.io.*; import java.util.*; public class Main {     public static void main(String[] args) throws Exception {         Scanner sc = new Scanner(System.in);         String str = sc.nextLine();         int n = str.length();         Stack<Character> s = new Stack<>();         for(int i=0;i<n;i++){             char ch = str.charAt(i);             if(ch == '[')                 s.push(']');             else if(ch == '{'